canon 5d (1d) soft touch exposure button failure

There was a problem with a 5d (Mk I) body. The 2. contact of the exposure button was not working.

After disassembling there was nothing to see, but verified with a multimeter there was no contact by pressing it to the second position. Stage 1. was OK.

image

The contacts are made of spring-steel (or highly elastic steel in any case), the end is gold plated. there was no sign of corrosion.

I soldered the other end to the flex-cable. Checked with the multimeter – it OK now.

I assembled the camera, a new check – it was working.

It’s very annoying, You can loose a lot of picture because a simple could soldering point.

In the last 3 years I’ve seen 2 pieces of 5d MkI and 1 piece of 1D Mk II with this problem.

Advertisements

About canonrepair

Ruzsa János. Amatőr fotós, Canon DSLR váz. Amateur photographer. Canon DSLR user.
This entry was posted in General topics. Bookmark the permalink.

2 Responses to canon 5d (1d) soft touch exposure button failure

  1. Gáll Ferenc says:

    Hi,
    If the 5D has a “soft touch” exp button, then my 40D has “hard touch” exp button… And so is the exp button on the chinese grip for 7D… What do you think, should I change this buttons with soft ones?

    • canonrepair says:

      5d button is totally different construction fom the other ones.
      You can change the buttons in the chinese grips – the problem is with the encoder-disks. Anyway, You can change them too – the chines grips which I1ve seen are of very-very poor quality. are

Opinion, question?

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s